Windows Section 4
Documentation

From POV-Wiki
Jump to: navigation, search

This document is protected, so submissions, corrections and discussions should be held on this documents talk page.


Contents

Windows

This section gives you a short run-down on the three main window elements that you will need to deal with - the Main Window, the Message Window, and the Render Window.

The Main Window

win-mainwindow.png

POV-Ray for Windows main window

The Toolbar

The toolbar contains a number of buttons and two controls. The buttons are labelled and should be self-explanatory. The purpose of the two controls, which are the pre-set rendering options combobox and the toolbar command-line, are discussed below.

Preset Rendering Options

win-quickres.png

This listbox contains a list of pre-set rendering options that you can choose just by clicking on one of them. By default, the list contains resolution and anti-aliasing related options, however, any POV-Ray option can be specified in the INI file that the list in the listbox is built from. It is easy to add your own entries to this list; see the section titled Adding New Resolutions for instructions.

Preset rendering options listbox

Note: Options entered on the POV-Ray command-line (via the toolbar, the command-line dialog, or the pvengine.exe command-line) will override any options specified by the above listbox.

Toolbar Command Line

The toolbar command-line is a shortcut to the command-line that is found in the Command Line Dialog. In past versions of POV-Ray for Windows, the key combination Alt+C would bring up the command-line dialog; now it will instead shift focus to the toolbar command-line. The command-line dialog is still accessible via the Render Menu, as before.

win-toolbarcmdline.png

Toolbar command line edit box

Once the toolbar command-line has focus, you may return focus to the editor or message window by pressing ESCAPE. Pressing ENTER will start a render. Any valid generic POV-Ray command-line switch can be used in this command-line, including INI options. See the Options Reference for a full list.

Hint: The Editor Context Menu has a handy shortcut for copying commonly-used command-lines from your scene files into the command-line field.

The Status Bar

At the bottom of the main window is a status bar. The left part of the status bar contains an information and help field. After that comes the current line and column of the editor caret, followed by a panel that shows 'INS' for editor insert mode, and 'OVR' for overwrite mode. Next to this you will find a Pixel-Per-Second indicator and a clock showing time elapsed (in days-hours-minutes-seconds) since the beginning of the last render job. This clock stops when the job completes. Note that on extremely slow renders, the PPS indicator may change to showing PPM (pixels per minute), or PPH (pixels per hour). Note also that the clock shows only elapsed time - not CPU time. As Windows is a multi-tasking operating system the two are not the same (though if you are running no other applications they will be fairly close).

The Tab Control

Displayed within the main window is a tabbed control. Using this you may select either the Message window or an Editor window (if a file is open) to be displayed within the main window. You may also switch tabs by using the 'Alt+Left Arrow', 'Alt+Right Arrow', 'Ctrl+Tab' or 'Shift+Ctrl+Tab' keyboard shortcuts.

Hovering your mouse over an editor tab will cause the name of the file to be shown in a hint. Right-clicking on it will pop up a menu providing the option to copy the full filename to the clipboard, open the folder containing the file in Windows Explorer, close the file, close all files other than the tab's file, move the tab left and move the tab right. Middle-clicking on it will close the tab. Note that you can also assign keyboard shortcuts to these actions.

Note that POV-Ray for Windows does not support MDI (the Multiple Document Interface). This is by design. You can only display one window at a time (with the exception that you can see a portion of the Message window from an editor window when rendering, and that the editor itself can split the edit pane into several views).

The Message Window

The message window displays text output from the POV-Ray raytracing engine. You'll find such things as render setting info, parse/render statistics, and parse warnings/errors displayed here. It has its own Context Menu.

You can change the background of the message window, along with its font and font color, from the Options|Message Window menu. The Edit menu allows you to copy the currently visible message pane to the clipboard as text (it is not possible to select portions of the text), and to erase the messages.

By default, each time you run a render, the message pane is cleared. If you wish new messages to be appended to the end of the existing messages you can turn on 'Preserve Messages' in the options menu.

The Editor Window

WinImgCmwindow.gif

The editor window

An Editor Window shows a file which has been opened for editing. It has its own Context Menu. There will be one editor window for each open file (maximum 32). The particular editor window being shown depends on the tab control that contains it.

There are an extensive set of options available for customizing the appearance and function of the editor window. See the sections on Using the Internal Editor, Configuring the Internal Editor, the Editor Menu, the Text Menu, and the Editor Preferences Dialog.

The Render Window

win-renderwin1.png

The Render Window pops up whenever you render a scene with the POV-Ray 3 display option (+d) set. The Render Window shows the scene as it is being rendered. The window is updated in blocks (default 32x32 pixels) as each render thread sends through its most recent result. It has its own Context Menu. If you close the Render Window you can re-display it by selecting Re-display from the Render Window submenu in the Options Menu, or by pressing the 'Show' button on the toolbar.

The render window

Warning: Just because you can see the image in the Render Window does not mean it is being saved to disk, or that it can be saved to disk. In many cases the data stored for display purposes is different than the data stored in an output file. If you don't have Output_To_File switched ON (this is the default, unless you have turned it off) then you will not get an output file and once the render is finished it is too late. If you want an output file you must select it before you start rendering.

We realize that this is different from many Windows programs, but the resources needed to store a full version of a rendered image in memory (especially if it's large) could often be best used elsewhere. The Render Window is only meant to be a preview of the final image. It is there for convenience.

Don't forget that if you choose (via an INI file) to have images written to a default directory, then that is where they will be unless you override this behavior. If you didn't select this option then the file will be written to the directory containing the scene file. Specifying an output file name that consists of only a path, such as c:\images\, will cause the output file to be written to that directory. POV-Ray determines if the filename is a path by looking at the last character and making sure that it is a '\'. The directory must already exist.

Note: To disable the Render Window, you must specify the -d option on the command-line, or Display=Off on the command-line or in one of the INI files processed. Simply closing the render window after it is created does not free up the memory used by it.

If you are running a high-resolution render, and have a high-color or true-color display, you can save RAM by turning the render window off. The amount of RAM used by the render window can be calculated as render width * render height * 3 bytes (if using 24 bits per pixel for your video display) or x 4 if using 32bpp. Most modern PC's will use either 24 or 32bpp. For example, a render of a 1024x768 pixel image on a 24bpp system will require about 2.4 megabytes of image buffer (even if you hide or minimize the render window). The only way to avoid this is to turn the render window off before the render starts.

If you have a high or true color display, selecting the 'Options|Render Window|Force 8-bit Display' option will cause only one-third of the memory to be allocated for the render bitmap, since the data will be stored (and displayed) as 8-bit pixels instead of true-color (24-bit). Needless to say, this has absolutely no effect on the output file.

See also Speed Considerations.


Command-Line Options Menus


This document is protected, so submissions, corrections and discussions should be held on this documents talk page.

Personal tools
Variants
Actions
Content
Other Pages
Toolbox