Reference:Version Directive

From POV-Wiki
Revision as of 11:07, 26 June 2017 by Jholsenback (talk | contribs) (minor)
Jump to navigation Jump to search

As POV-Ray has evolved from version 1.0 through 3.8 we have made every effort to maintain some amount of backwards compatibility with earlier versions. Some old or obsolete features can be handled directly without any special consideration by the user. Some old or obsolete features can no longer be handled at all. However some old features can still be used if you warn POV-Ray that this is an older scene. The #version directive can be used to switch version compatibility to different setting several times throughout a scene file. The syntax is:

  #version FLOAT;

Note: There should be a semi-colon after the float expression in a #version directive. This semi-colon is introduced in POV-Ray version 3.1. If omitted, it generates a warning and some macros may not work properly.

Additionally you may use the Version=n.n option or the +MVn.n switch to establish the initial setting. See Language Version for details. For example, one feature introduced in 2.0 that was incompatible with any 1.0 scene files is the parsing of float expressions. Using #version 1.0 turns off expression parsing as well as many warning messages so that nearly all 1.0 files will still work.

Note: Some obsolete or re-designed features are totally unavailable in the current version of POV-Ray REGARDLESS OF THE VERSION SETTING. Details on these features are noted throughout this documentation.

The built-in float identifier version contains the current setting of the version compatibility option. See Float Expressions: Built-in Variables. Together with the built-in version identifier the #version directive allows you to save and restore the previous values of this compatibility setting. The new #local identifier option is especially useful here. For example, suppose is in version 3.5 format. At the top of the file you could put:

  #local Temp_Vers = version;  // Save previous value
  #version 3.5;                // Change to 3.5 mode
    ...                        // Version 3.5 stuff goes here...
  #version Temp_Vers;          // Restore previous version

As of version 3.7, there has been a requirement implemented. In order to obtain full version 3.7 functionality, you MUST specify the #version 3.7 directive in your scene file. Prior to a #version directive appearing, the version defaults to 3.62. Additionally, if the first #version appears after any other declaration, or a #version directive does not appear at all, a post-parse warning is issued, and a Change as of POV-Ray 3.8 or later it is now considered an outright error to use #version 3.8 or higher in a main scene file that does not start with a #version directive.

If you do need to do some processing before you decide on a version compatibility option, start your scene with the following construct:

  #version version;

Note that unless the version compatibility option has explicitly been set by the INI file option Version=n.n or by the +MVn.n command-line switch, version evaluates to the actual POV-Ray software version when used inside the first #version statement, even in version 3.8 or later where it evaluates to the effective version compatibility option anywhere else.

Warning: The version directive and command-line setting no longer provide compatibility with most rendering bugs in versions prior to POV-Ray 3.5. However, compatibility with the scene language is provided for scenes as old as POV-Ray 1.0 just as in all previous versions of POV-Ray. Nevertheless, we strongly recommend you update scenes at least to POV-Ray 3.5 syntax if you plan to use them in future versions of POV-Ray.