Contents
Documentation

From POV-Wiki
Jump to: navigation, search

This document is protected, so submissions, corrections and discussions should be held on this documents talk page.


DocImgPovlogotext.jpg

Persistence Of Vision Raytracer™

Welcome

Welcome to the POV-Ray version 3.7.x documentation repository ... if you're looking for the most up to date documentation, you've found it! This content is used to generate the documentation included with the distribution, so occasionally it can get ahead of the current release.

The content has been divided into the following five major sections:

  1. Introduction to POV-Ray
  2. POV-Ray Reference
  3. POV-Ray for Windows
  4. POV-Ray for Mac OS
  5. POV-Ray for Unix

New to POV-Ray? You'd most likely want to begin with the tutorial section. Need to locate something quickly? The list of identifiers and keywords is a good place to start. See the changes and new features summary for what's new with this release.

Introduction to POV-Ray

1.1 Introduction
1.1.1 Program Description
1.1.2 What is Ray-Tracing?
1.1.3 What is POV-Ray?
1.1.4 Features
1.1.4.1 Changes and New Features Summary
1.1.4.1.1 Version 3.7.1
1.1.4.1.2 Version 3.7.0
1.1.5 Trademarks
1.1.6 The Early History of POV-Ray
1.1.6.1 The Original Creation Message
1.1.6.2 The Name
1.1.6.3 A Historic 'Version History'
1.1.7 How Do I Begin?
1.1.8 Notation and Basic Assumptions
1.2 Getting Started
1.2.1 Our First Image
1.2.1.1 Understanding POV-Ray's Coordinate System
1.2.1.2 Adding Standard Include Files
1.2.1.3 Adding a Camera
1.2.1.4 Describing an Object
1.2.1.5 Adding Texture to an Object
1.2.1.6 Defining a Light Source
1.2.2 Basic Shapes
1.2.2.1 Box Object
1.2.2.2 Cone Object
1.2.2.3 Cylinder Object
1.2.2.4 Plane Object
1.2.2.5 Torus Object
1.2.3 CSG Objects
1.2.3.1 What is CSG?
1.2.3.2 CSG Union
1.2.3.3 CSG Intersection
1.2.3.4 CSG Difference
1.2.3.5 CSG Merge
1.2.3.6 CSG Pitfalls
1.2.3.6.1 Co-incident Surfaces
1.2.4 The Light Source
1.2.4.1 The Pointlight Source
1.2.4.2 The Spotlight Source
1.2.4.3 The Cylindrical Light Source
1.2.4.4 The Area Light Source
1.2.4.5 The Ambient Light Source
1.2.4.6 Light Source Specials
1.2.4.6.1 Using Shadowless Lights
1.2.4.6.2 Assigning an Object to a Light Source
1.2.4.6.3 Using Light Fading
1.2.5 Simple Texture Options
1.2.5.1 Surface Finishes
1.2.5.2 Adding Bumpiness
1.2.5.3 Creating Color Patterns
1.2.5.4 Pre-defined Textures
1.2.6 Using the Camera
1.2.6.1 Using Focal Blur
1.2.7 POV-Ray Coordinate System
1.2.7.1 Transformations
1.2.7.1.1 Translate
1.2.7.1.2 Scale
1.2.7.1.3 Rotate
1.2.7.1.4 Matrix
1.2.7.2 Transformation Order
1.2.7.3 Inverse Transform
1.2.7.4 Transform Identifiers
1.2.7.5 Transforming Textures and Objects
1.2.8 Setting POV-Ray Options
1.2.8.1 Command Line Switches
1.2.8.2 Using INI Files
1.2.8.3 Using the POVINI Environment Variable
1.3 Advanced Features
1.3.1 Spline Based Shapes
1.3.1.1 Lathe Object
1.3.1.1.1 Understanding The Concept of Splines
1.3.1.2 Surface of Revolution Object
1.3.1.3 Prism Object
1.3.1.3.1 Teaching An Old Spline New Tricks
1.3.1.3.2 Smooth Transitions
1.3.1.3.3 Multiple Sub-Shapes
1.3.1.3.4 Conic Sweeps And The Tapering Effect
1.3.1.4 Sphere Sweep Object
1.3.1.5 Bicubic Patch Object
1.3.1.6 Text Object
1.3.2 Polygon Based Shapes
1.3.2.1 Mesh Object
1.3.2.2 Mesh2 Object
1.3.2.2.1 Smooth triangles and mesh2
1.3.2.2.2 UV mapping and mesh2
1.3.2.2.3 A separate texture per triangle
1.3.2.3 Polygon Object
1.3.3 Other Shapes
1.3.3.1 Blob Object
1.3.3.1.1 Component Types and Other New Features
1.3.3.1.2 Complex Blob Constructs and Negative Strength
1.3.3.2 Height Field Object
1.3.3.3 Isosurface Object
1.3.3.3.1 Simple functions
1.3.3.3.2 Several surfaces
1.3.3.3.3 Non-linear functions
1.3.3.3.4 Specifying functions
1.3.3.3.5 Internal functions
1.3.3.3.6 Combining isosurface functions
1.3.3.3.7 Noise and pigment functions
1.3.3.3.8 Conditional directives and loops
1.3.3.3.9 Transformations on functions
1.3.3.3.10 Improving Isosurface Speed
1.3.3.4 Poly Object
1.3.3.4.1 Creating the polynomial function
1.3.3.4.2 Writing the polynomial vector
1.3.3.4.3 Polynomial made easy
1.3.3.5 Superquadric Ellipsoid Object
1.3.4 Gamma Handling
1.3.4.1 Setting Up Your Display
1.3.4.2 Setting Up POV-Ray
1.3.4.3 Gamma in Output Images
1.3.4.4 Setting Up Your Scene
1.3.4.5 Gamma in Literal Colors
1.3.4.6 Gamma in Input Images
1.3.4.7 Gamma in Legacy Scenes
1.3.5 Advanced Texture Options
1.3.5.1 Pigments
1.3.5.1.1 Using Color List Pigments
1.3.5.1.2 Using Pigment and Patterns
1.3.5.1.3 Using Pattern Modifiers
1.3.5.1.4 Using Transparent Pigments and Layered Textures
1.3.5.1.5 Using Pigment Maps
1.3.5.2 Normals
1.3.5.2.1 Using Basic Normal Modifiers
1.3.5.2.2 Blending Normals
1.3.5.2.3 Slope Map Tutorial
1.3.5.2.3.1 Slopes, what are they?
1.3.5.2.3.2 Syntax of a slope map
1.3.5.2.3.3 Examples of slope maps
1.3.5.3 Finishes
1.3.5.3.1 Using Ambient
1.3.5.3.2 Using Emission
1.3.5.3.3 Using Surface Highlights
1.3.5.3.4 Using Reflection, Metallic and Metallic
1.3.5.3.5 Using Iridescence
1.3.5.4 Working With Pigment Maps
1.3.5.5 Working With Normal Maps
1.3.5.6 Working With Texture Maps
1.3.5.7 Working With List Textures
1.3.5.8 What About Tiles?
1.3.5.9 Average Function
1.3.5.10 Working With Layered Textures
1.3.5.10.1 Declaring Layered Textures
1.3.5.10.2 Another Layered Textures Example
1.3.5.11 When All Else Fails: Material Maps
1.3.5.12 Limitations Of Special Textures
1.3.6 Using Atmospheric Effects
1.3.6.1 The Background
1.3.6.2 The Sky Sphere
1.3.6.2.1 Creating a Sky with a Color Gradient
1.3.6.2.2 Adding the Sun
1.3.6.2.3 Adding Some Clouds
1.3.6.3 The Fog
1.3.6.3.1 A Constant Fog
1.3.6.3.2 Setting a Minimum Translucency
1.3.6.3.3 Creating a Filtering Fog
1.3.6.3.4 Adding Some Turbulence to the Fog
1.3.6.3.5 Using Ground Fog
1.3.6.3.6 Using Multiple Layers of Fog
1.3.6.3.7 Fog and Hollow Objects
1.3.6.4 The Rainbow
1.3.6.4.1 Starting With a Simple Rainbow
1.3.6.4.2 Increasing the Rainbow's Translucency
1.3.6.4.3 Using a Rainbow Arc
1.3.7 Simple Media Tutorial
1.3.7.1 Types of media
1.3.7.2 Some media concepts
1.3.7.3 Simple media examples
1.3.7.3.1 Emitting media
1.3.7.3.2 Absorbing media
1.3.7.3.3 Scattering media
1.3.7.4 Multiple medias inside the same object
1.3.7.5 Media and transformations
1.3.7.6 A more advanced example of scattering media
1.3.7.7 Media and photons
1.3.8 Radiosity
1.3.8.1 Introduction
1.3.8.2 Radiosity with conventional lighting
1.3.8.3 Radiosity without conventional lighting
1.3.8.4 Normals and Radiosity
1.3.8.5 Performance considerations
1.3.9 Making Animations
1.3.9.1 The Clock Variable: Key To It All
1.3.9.2 Clock Dependant Variables And Multi-Stage Animations
1.3.9.3 The Phase Keyword
1.3.9.4 Do Not Use Jitter Or Crand
1.3.9.5 INI File Settings
1.3.10 While-loop tutorial
1.3.10.1 What a while-loop is and what it is not
1.3.10.2 How does a single while-loop work?
1.3.10.3 How do I make a while-loop?
1.3.10.4 What is a condition and how do I make one?
1.3.10.5 What about loop types other than simple for-loops?
1.3.10.6 What about nested loops?
1.3.10.7 Mixed-type nested loops
1.3.10.8 Other things to note
1.3.11 SDL tutorial: A raytracer
1.3.11.1 Introduction
1.3.11.2 The idea and the code
1.3.11.3 Short introduction to raytracing
1.3.11.4 Global settings
1.3.11.5 Scene definition
1.3.11.6 Initializing the raytracer
1.3.11.7 Ray-sphere intersection
1.3.11.7.1 Inner workings of a macro
1.3.11.7.2 The ray-sphere intersection macro
1.3.11.8 The Trace macro
1.3.11.8.1 Calculating the closest intersection
1.3.11.8.2 If the ray doesn't hit anything
1.3.11.8.3 Initializing color calculations
1.3.11.8.4 Going through the light sources
1.3.11.8.5 Shadow test
1.3.11.8.6 Diffuse lighting
1.3.11.8.7 Specular lighting
1.3.11.8.8 Reflection Calculation
1.3.11.9 Calculating the image
1.3.11.10 Creating the colored mesh
1.3.11.10.1 The structure of the mesh
1.3.11.10.2 Creating the mesh
1.3.11.10.3 Creating the vertex points
1.3.11.10.4 Creating the textures
1.3.11.10.5 Creating the triangles
1.3.11.11 The Camera-setup
1.4 Questions and Tips
1.5 Appendices
1.5.1 Contacting the Authors
1.5.2 POV-Ray License
1.5.3 Contact Information
1.5.4 Support Library Licenses
1.5.4.1 OpenEXR
1.5.5 Citing POV-Ray in Academic Publications
1.5.6 Contributors to POV-Ray
1.5.7 Thanks
1.5.8 What to do if you don't have POV-Ray
1.5.8.1 Which Version of POV-Ray should you use?
1.5.8.1.1 Microsoft Windows
1.5.8.1.2 Apple Macintosh
1.5.8.1.3 Linux/Unix
1.5.8.1.4 All Versions
1.5.8.2 Where to Find POV-Ray Files
1.5.8.2.1 World Wide Website www.povray.org
1.5.9 Suggested Reading

POV-Ray Reference

2.1 Introduction
2.2 Command-line Options
2.2.1 Animation Options
2.2.1.1 External Animation Loop
2.2.1.2 Internal Animation Loop
2.2.1.3 Subsets of Animation Frames
2.2.1.4 Cyclic Animation
2.2.1.5 Field Renderings
2.2.2 General Output Options
2.2.2.1 Height and Width of Output
2.2.2.2 Max Image Buffer Memory
2.2.2.3 Partial Output Options
2.2.2.4 Interrupting Options
2.2.2.5 Resuming Options
2.2.3 Display Output Options
2.2.3.1 Display Hardware Settings
2.2.3.2 Setting your Display Gamma
2.2.3.3 Display Related Settings
2.2.3.4 Mosaic Preview
2.2.4 File Output Options
2.2.4.1 Output File Type
2.2.4.2 Output File Name
2.2.4.3 Output File Buffer
2.2.4.4 Output File Dithering
2.2.4.5 Output File Gamma
2.2.4.6 CPU Utilization Histogram
2.2.5 Scene Parsing Options
2.2.5.1 Constant
2.2.5.2 Include File Name
2.2.5.3 Library Paths
2.2.5.4 Language Version
2.2.6 Shell Command Options
2.2.6.1 String Substitution in Shell Commands
2.2.6.2 Shell Command Sequencing
2.2.6.3 Shell Command Return Actions
2.2.7 Text Output Options
2.2.7.1 Text Streams
2.2.7.2 Console Text Output
2.2.7.3 Directing Text Streams to Files
2.2.7.4 Warning Levels
2.2.7.5 Help Screen Switches
2.2.8 Tracing Options
2.2.8.1 Symmetric MultiProcessing
2.2.8.2 Render Block Size
2.2.8.2.1 Render Pattern
2.2.8.2.2 Render Block Step
2.2.8.3 Quality Settings
2.2.8.4 Automatic Bounding Control
2.2.8.5 Removing User Bounding
2.2.8.6 BSP Bounding
2.2.8.7 Anti-Aliasing Options
2.2.8.8 Radiosity Options
2.2.8.8.1 Radiosity High Reproducibility
2.2.8.8.2 Radiosity Load and Save
2.2.8.8.3 Radiosity Vain Pretrace
2.3 Scene Description Language
2.3.1 Language Basics
2.3.1.1 Notation and Basic Assumptions
2.3.1.2 Keywords
2.3.1.3 Identifiers
2.3.1.4 Comments
2.3.1.5 Numeric Expressions
2.3.1.5.1 Literals
2.3.1.5.2 Identifiers
2.3.1.5.3 Operators
2.3.1.5.4 Functions
2.3.1.5.5 Built-in Constants
2.3.1.5.6 Built-in Variables
2.3.1.6 Vector Expressions
2.3.1.6.1 Literals
2.3.1.6.2 Identifiers
2.3.1.6.3 Operators
2.3.1.6.4 Operator Promotion
2.3.1.6.5 Functions
2.3.1.6.6 Built-in Constants
2.3.1.6.7 Dot Item Access for Vectors
2.3.1.7 Color Expressions
2.3.1.7.1 Color Vectors
2.3.1.7.2 sRGB Colors
2.3.1.7.3 Color Keywords
2.3.1.7.4 Color Identifiers
2.3.1.7.5 Color Operators
2.3.1.7.6 Dot Item Access for Colors
2.3.1.7.7 Common Color Pitfalls
2.3.1.8 Function
2.3.1.8.1 Sum and Product functions
2.3.1.8.2 Functions and Macros
2.3.1.8.3 Declaring User-Defined Float Functions
2.3.1.8.4 Declaring User-Defined Vector Functions
2.3.1.8.5 Declaring User-Defined Color Functionss
2.3.1.8.6 Internal Pre-Defined Functions
2.3.1.9 Strings
2.3.1.9.1 String Literals
2.3.1.9.2 String Identifiers
2.3.1.9.3 String Relational Operators
2.3.1.9.4 String Functions
2.3.1.9.5 Built-in Variables
2.3.1.10 Array
2.3.1.10.1 Declaring Arrays
2.3.1.10.2 Array Initializers
2.3.1.11 Spline
2.3.1.11.1 Splines and Macros
2.3.1.12 Transformations
2.3.1.12.1 Translate
2.3.1.12.2 Scale
2.3.1.12.3 Rotate
2.3.1.12.4 Matrix
2.3.2 Language Directives
2.3.2.1 Include Directive
2.3.2.2 Declare and Local Directives
2.3.2.2.1 Declaring identifiers
2.3.2.2.2 declare vs. local
2.3.2.2.3 Identifier Name Collisions
2.3.2.2.4 Destroying Identifiers with undef
2.3.2.2.5 Deprecation Support
2.3.2.3 File I/O Directives
2.3.2.3.1 The fopen Directive
2.3.2.3.2 The fclose Directive
2.3.2.3.3 The read Directive
2.3.2.3.4 The write Directive
2.3.2.4 Default Directive
2.3.2.5 Version Directive
2.3.2.6 Conditional Directives
2.3.2.6.1 The if...else...end Directives
2.3.2.6.2 The ifdef and ifndef Directives
2.3.2.6.3 The for Directive
2.3.2.6.4 The switch, case, range and break Directives
2.3.2.6.5 The while...end Directive
2.3.2.7 User Message Directives
2.3.2.7.1 Text Message Streams
2.3.2.7.2 Text Formatting
2.3.2.8 User Defined Macros
2.3.2.8.1 The macro Directive
2.3.2.8.2 Invoking Macros
2.3.2.8.3 Are POV-Ray Macros a Function or a Macro?
2.3.2.8.4 Returning a Value Like a Function
2.3.2.8.5 Returning Values Via Parameters
2.3.2.8.6 Optional Parameters
2.3.2.8.7 Macro Caching
2.4 Scene File Basics
2.4.1 Global Settings
2.4.1.1 ADC_Bailout
2.4.1.2 Ambient_Light
2.4.1.3 Assumed_Gamma
2.4.1.4 HF_Gray_16
2.4.1.5 Irid_Wavelength
2.4.1.6 Charset
2.4.1.7 Max_Trace_Level
2.4.1.8 Max_Intersections
2.4.1.9 Mm_Per_Unit
2.4.1.10 Number_Of_Waves
2.4.1.11 Noise_generator
2.4.1.12 Subsurface
2.4.2 Camera
2.4.2.1 Placing the Camera
2.4.2.1.1 Location and Look_At
2.4.2.1.2 The Sky Vector
2.4.2.1.3 Angles
2.4.2.1.4 The Direction Vector
2.4.2.1.5 Up and Right Vectors
2.4.2.1.6 Aspect Ratio
2.4.2.1.7 Handedness
2.4.2.1.8 Transforming the Camera
2.4.2.2 Types of Projection
2.4.2.2.1 Perspective projection
2.4.2.2.2 Orthographic projection
2.4.2.2.3 Mesh projection
2.4.2.2.3.1 Rays Per Pixel
2.4.2.2.3.2 Distribution Type
2.4.2.2.3.3 Max Distance
2.4.2.2.3.4 Mesh Object
2.4.2.2.3.5 About the Location Vector
2.4.2.2.3.6 About the Direction Vector
2.4.2.2.3.7 The Smooth Modifier
2.4.2.2.4 Fisheye projection
2.4.2.2.5 Ultra wide angle projection
2.4.2.2.6 Omnimax projection
2.4.2.2.7 Panoramic projection
2.4.2.2.8 Cylindrical projection
2.4.2.2.9 Spherical projection
2.4.2.2.10 User defined projection
2.4.2.3 Focal Blur
2.4.2.4 Camera Ray Perturbation
2.4.2.5 Camera Identifiers
2.4.3 Lighting Types
2.4.3.1 Light Source
2.4.3.1.1 Point Lights
2.4.3.1.2 Spotlights
2.4.3.1.3 Cylindrical Lights
2.4.3.1.4 Parallel Lights
2.4.3.1.5 Area Lights
2.4.3.1.6 Shadowless Lights
2.4.3.1.7 Looks Like
2.4.3.1.8 Projected Through
2.4.3.1.9 Light Fading
2.4.3.1.10 Atmospheric Media Interaction
2.4.3.1.11 Atmospheric Attenuation
2.4.3.2 Light Group
2.4.3.3 Radiosity
2.4.3.3.1 Radiosity Basics
2.4.3.3.2 How Radiosity Works
2.4.3.3.3 Adjusting Radiosity
2.4.3.3.3.1 adc_bailout
2.4.3.3.3.2 always_sample
2.4.3.3.3.3 brightness
2.4.3.3.3.4 count
2.4.3.3.3.5 error_bound
2.4.3.3.3.6 gray_threshold
2.4.3.3.3.7 low_error_factor
2.4.3.3.3.8 max_sample
2.4.3.3.3.9 maximum_reuse
2.4.3.3.3.10 minimum_reuse
2.4.3.3.3.11 nearest_count
2.4.3.3.3.12 pretrace_start and pretrace_end
2.4.3.3.3.13 recursion_limit
2.4.3.3.4 Configuring Radiosity
2.4.3.3.4.1 Importance
2.4.3.3.4.2 Media and Radiosity
2.4.3.3.4.3 No Radiosity
2.4.3.3.4.4 Normal and Radiosity
2.4.3.3.4.5 Save and Load Radiosity Data
2.4.3.3.4.6 Subsurface and Radiosity
2.4.3.3.5 Tips on Radiosity
2.4.3.4 Photons
2.4.3.4.1 Examples
2.4.3.4.2 Using Photon Mapping in Your Scene
2.4.3.4.3 Photon Global Settings
2.4.3.4.4 Shooting Photons at an Object
2.4.3.4.5 Photons and Light Sources
2.4.3.4.6 Photons and Media
2.4.3.4.7 Photons FAQ
2.4.3.4.8 Photon Tips
2.4.3.4.9 Advanced Techniques
2.4.3.4.9.1 Autostop
2.4.3.4.9.2 Adaptive Search Radius
2.4.3.4.9.3 Photons and Dispersion
2.4.3.4.9.4 Saving and Loading Photon Maps
2.5 The Object Zoo
2.5.1 Object
2.5.1.1 Finite Solid Primitives
2.5.1.1.1 Blob
2.5.1.1.2 Box
2.5.1.1.3 Cone
2.5.1.1.4 Cylinder
2.5.1.1.5 Height Field
2.5.1.1.6 Isosurface
2.5.1.1.7 Julia Fractal
2.5.1.1.8 Lathe
2.5.1.1.9 Lemon
2.5.1.1.10 Ovus
2.5.1.1.11 Parametric
2.5.1.1.12 Prism
2.5.1.1.13 Sphere
2.5.1.1.14 Sphere Sweep
2.5.1.1.15 Superquadric Ellipsoid
2.5.1.1.16 Surface of Revolution
2.5.1.1.17 Text
2.5.1.1.18 Torus
2.5.1.2 Finite Patch Primitives
2.5.1.2.1 Bicubic Patch
2.5.1.2.2 Disc
2.5.1.2.3 Mesh
2.5.1.2.3.1 Solid Mesh
2.5.1.2.4 Mesh2
2.5.1.2.4.1 Smooth and Flat triangles in the same mesh
2.5.1.2.4.2 Mesh Triangle Textures
2.5.1.2.5 Polygon
2.5.1.2.6 Triangle
2.5.1.2.7 Smooth Triangle
2.5.1.3 Infinite Solid Primitives
2.5.1.3.1 Plane
2.5.1.3.2 Poly
2.5.1.3.3 Cubic
2.5.1.3.4 Quartic
2.5.1.3.5 Polynomial
2.5.1.3.6 Quadric
2.5.1.4 Constructive Solid Geometry
2.5.1.4.1 Inside and Outside
2.5.1.4.2 Union
2.5.1.4.2.1 Split Union
2.5.1.4.3 Intersection
2.5.1.4.4 Difference
2.5.1.4.5 Merge
2.5.1.5 Object Modifiers
2.5.1.5.1 Clipped By Object Modifier
2.5.1.5.2 Bounded By Object Modifier
2.5.1.5.3 Material
2.5.1.5.4 Hollow Object Modifier
2.5.1.5.5 Inverse Object Modifier
2.5.1.5.6 No Shadow Object Modifier
2.5.1.5.7 No Image Object Modifier
2.5.1.5.8 No Reflection Object Modifier
2.5.1.5.9 Double Illuminate Object Modifier
2.5.1.5.10 No Radiosity Object Modifier
2.5.1.5.11 Sturm Object Modifier
2.6 Embellishments
2.6.1 Texture
2.6.1.1 Pigment
2.6.1.1.1 Solid Color Pigments
2.6.1.1.2 Color Map
2.6.1.1.3 Pigment Map
2.6.1.1.4 Color List Pigments
2.6.1.1.5 Quick Color
2.6.1.2 Normal
2.6.1.2.1 Normal Map
2.6.1.2.2 Slope Map
2.6.1.2.2.1 Normals, Accuracy
2.6.1.2.3 Bump Map
2.6.1.2.3.1 Specifying a Bump Map
2.6.1.2.3.2 Bump_Size
2.6.1.2.3.3 Use_Index and Use_Color
2.6.1.2.4 Scaling normals
2.6.1.3 Finish
2.6.1.3.1 Ambient
2.6.1.3.2 Emission
2.6.1.3.3 Diffuse Reflection Items
2.6.1.3.3.1 Diffuse
2.6.1.3.3.2 Brilliance
2.6.1.3.3.3 Crand Graininess
2.6.1.3.3.4 Subsurface Light Transport
2.6.1.3.4 Highlights
2.6.1.3.4.1 Phong Highlights
2.6.1.3.4.2 Specular Highlight
2.6.1.3.4.3 Metallic Highlight Modifier
2.6.1.3.5 Specular Reflection
2.6.1.3.6 Conserve Energy for Reflection
2.6.1.3.7 Iridescence
2.6.1.4 Halo
2.6.1.5 Patterned Textures
2.6.1.5.1 Texture Maps
2.6.1.5.2 Tiles
2.6.1.5.3 Material Maps
2.6.1.5.3.1 Specifying a Material Map
2.6.1.6 Layered Textures
2.6.1.7 UV Mapping
2.6.1.7.1 Supported Objects
2.6.1.7.2 UV Vectors
2.6.1.8 Triangle Texture Interpolation
2.6.1.9 Interior Texture
2.6.1.10 Cutaway Textures
2.6.2 Pattern
2.6.2.1 General Patterns
2.6.2.1.1 Agate Pattern
2.6.2.1.2 Boxed Pattern
2.6.2.1.3 Bozo Pattern
2.6.2.1.4 Brick Pattern
2.6.2.1.5 Bumps Pattern
2.6.2.1.6 Cubic Pattern
2.6.2.1.7 Cylindrical Pattern
2.6.2.1.8 Density File Pattern
2.6.2.1.8.1 df3 file format
2.6.2.1.9 Dents Pattern
2.6.2.1.10 Facets Pattern
2.6.2.1.11 Fractal Pattern
2.6.2.1.12 Function Pattern
2.6.2.1.12.1 What can be used
2.6.2.1.12.2 Function Image
2.6.2.1.13 Gradient Pattern
2.6.2.1.14 Granite Pattern
2.6.2.1.15 Leopard Pattern
2.6.2.1.16 Marble Pattern
2.6.2.1.17 Onion Pattern
2.6.2.1.18 Pavement Pattern
2.6.2.1.19 Pigment Pattern
2.6.2.1.20 Planar Pattern
2.6.2.1.21 Quilted Pattern
2.6.2.1.22 Radial Pattern
2.6.2.1.23 Ripples Pattern
2.6.2.1.24 Spherical Pattern
2.6.2.1.25 Spiral1 Pattern
2.6.2.1.26 Spiral2 Pattern
2.6.2.1.27 Spotted Pattern
2.6.2.1.28 Tiling Pattern
2.6.2.1.29 Waves Pattern
2.6.2.1.30 Wood Pattern
2.6.2.1.31 Wrinkles Pattern
2.6.2.2 Discontinuous Patterns
2.6.2.2.1 Cells Pattern
2.6.2.2.2 Checker Pattern
2.6.2.2.3 Crackle Pattern
2.6.2.2.4 Hexagon Pattern
2.6.2.2.5 Object Pattern
2.6.2.2.6 Square Pattern
2.6.2.2.7 Triangular Pattern
2.6.2.3 Normal-Dependent Patterns
2.6.2.3.1 Aoi Pattern
2.6.2.3.2 Slope Pattern
2.6.2.4 Special Patterns
2.6.2.4.1 Average Pattern
2.6.2.4.2 Image Pattern
2.6.2.4.3 Potential Pattern
2.6.2.4.4 User Defined Pattern
2.6.2.5 Pattern Modifiers
2.6.2.5.1 Transforming Patterns
2.6.2.5.2 Frequency and Phase
2.6.2.5.3 Waveforms
2.6.2.5.4 Noise Generators
2.6.2.5.5 Warp
2.6.2.5.5.1 Black Hole Warp
2.6.2.5.5.2 Repeat Warp
2.6.2.5.5.3 Turbulence Warp
2.6.2.5.5.4 Octaves
2.6.2.5.5.5 Lambda
2.6.2.5.5.6 Omega
2.6.2.5.5.7 Mapping using warps
2.6.2.5.5.8 Turbulence versus Turbulence Warp
2.6.2.5.5.9 Turbulence
2.6.2.6 Image Map
2.6.2.6.1 Specifying an Image Map
2.6.2.6.2 The Gamma Option
2.6.2.6.3 The Filter and Transmit Bitmap Modifiers
2.6.2.6.4 Using the Alpha Channel
2.6.2.7 Bitmap Modifiers
2.6.2.7.1 The once Option
2.6.2.7.2 The map_type Option
2.6.2.7.3 The interpolate Option
2.7 Special Effects
2.7.1 Atmospheric Effects
2.7.1.1 Atmospheric Media
2.7.1.2 Background
2.7.1.3 Fog
2.7.1.4 Sky Sphere
2.7.1.5 Rainbow
2.7.2 Media
2.7.2.1 Interior
2.7.2.1.1 Why are Interior and Media Necessary?
2.7.2.1.2 Empty and Solid Objects
2.7.2.1.3 Scaling objects with an interior
2.7.2.1.4 Refraction
2.7.2.1.5 Dispersion
2.7.2.1.5.1 Dispersion & Caustics
2.7.2.1.6 Attenuation
2.7.2.1.7 Simulated Caustics
2.7.2.1.8 Object Media
2.7.2.2 Media Types
2.7.2.2.1 Absorption
2.7.2.2.2 Emission
2.7.2.2.3 Scattering
2.7.2.3 Sampling Parameters & Methods
2.7.2.4 Density
2.7.2.4.1 General Density Modifiers
2.7.2.4.2 Density with color_map
2.7.2.4.3 Density Maps and Density Lists
2.7.2.4.4 Multiple Density vs. Multiple Media
2.8 Scene File Extras
2.8.1 Include Files
2.8.1.1 Main Files
2.8.1.1.1 Arrays.inc
2.8.1.1.2 Chars.inc
2.8.1.1.3 Colors.inc
2.8.1.1.3.1 Predefined colors
2.8.1.1.3.2 Color macros
2.8.1.1.4 Colors_ral.inc
2.8.1.1.5 Consts.inc
2.8.1.1.5.1 Vector constants
2.8.1.1.5.2 Map type constantss
2.8.1.1.5.3 Interpolation type constants
2.8.1.1.5.4 Fog type constants
2.8.1.1.5.5 Focal blur hexgrid constants
2.8.1.1.5.6 IORs
2.8.1.1.5.7 Dispersion amounts
2.8.1.1.5.8 Scattering media type constants
2.8.1.1.6 Debug.inc
2.8.1.1.7 Finish.inc
2.8.1.1.8 Functions.inc
2.8.1.1.8.1 Common Parameters
2.8.1.1.8.2 Cross Section Type
2.8.1.1.8.3 Field Strength
2.8.1.1.8.4 Field Limit
2.8.1.1.8.5 SOR Switch
2.8.1.1.8.6 SOR Offset
2.8.1.1.8.7 SOR Angle
2.8.1.1.8.8 Invert Isosurface
2.8.1.1.8.9 Internal Functions
2.8.1.1.8.10 Pre defined functions
2.8.1.1.8.11 Pattern functions
2.8.1.1.9 Glass.inc
2.8.1.1.9.1 Glass colors (with transparency)
2.8.1.1.9.2 Glass colors (without transparency, for fade_color)
2.8.1.1.9.3 Glass finishes
2.8.1.1.9.4 Glass interiors
2.8.1.1.9.5 Glass interior macros
2.8.1.1.10 Golds.inc
2.8.1.1.11 Logo.inc
2.8.1.1.12 Makegrass.inc
2.8.1.1.13 Math.inc
2.8.1.1.13.1 Float functions and macros
2.8.1.1.13.2 Vector functions and macros
2.8.1.1.13.3 Vector Analysis
2.8.1.1.14 Meshmaker.inc
2.8.1.1.15 Metals.inc
2.8.1.1.16 Rad_def.inc
2.8.1.1.17 Rand.inc
2.8.1.1.17.1 Flat Distributions
2.8.1.1.17.2 Other Distributions
2.8.1.1.17.3 Continuous Symmetric Distributions
2.8.1.1.17.4 Continuous Skewed Distributions
2.8.1.1.17.5 Discrete Distributions
2.8.1.1.18 Screen.inc
2.8.1.1.19 Shapes.inc
2.8.1.1.19.1 The HF Macros
2.8.1.1.20 Shapes2.inc
2.8.1.1.21 Shapes3.inc
2.8.1.1.22 Shapesq.inc
2.8.1.1.23 Skies.inc
2.8.1.1.24 Stars.inc
2.8.1.1.25 Stones.inc
2.8.1.1.26 Stdinc.inc
2.8.1.1.27 Strings.inc
2.8.1.1.28 Sunpos.inc
2.8.1.1.29 Textures.inc
2.8.1.1.29.1 Stones
2.8.1.1.29.2 Skies
2.8.1.1.29.3 Woods
2.8.1.1.29.4 Glass
2.8.1.1.29.5 Metals
2.8.1.1.29.6 Special textures
2.8.1.1.29.7 Texture and pattern macros
2.8.1.1.30 Transforms.inc
2.8.1.1.31 Woods.inc
2.8.1.1.32 Woodmaps.inc
2.8.1.2 Old Files
2.8.1.2.1 Glass_old.inc
2.8.1.2.1.1 Glass finishes
2.8.1.2.1.2 Glass textures
2.8.1.2.2 Shapes_old.inc
2.8.1.2.3 Stage1.inc
2.8.1.2.4 Stdcam.inc
2.8.1.2.5 Stones1.inc
2.8.1.2.6 Stones2.inc
2.8.1.3 Other Files
2.8.1.3.1 Font Files
2.8.1.3.2 Color Map Files
2.8.1.3.3 Image Files

POV-Ray for Windows

3.1 Introduction
3.1.1 What is POV-Ray for Windows?
3.1.2 ... And What Is It Not?
3.1.3 Who Can Use POV-Ray for Windows?
3.1.4 System Requirements
3.1.5 System Specific Features
3.1.5.1 What's new in POV-Ray for Windows
3.1.5.2 SYS File Type
3.1.5.3 System Specific Charset
3.1.6 Spelling
3.1.7 Reporting Bugs
3.1.8 Trademarks
3.1.9 Real-Time Raytracing
3.1.9.1 Clockless Animation
3.1.9.2 Video Capture
3.1.9.3 Options
3.1.9.4 Video Source
3.2 Getting Started
3.2.1 The Demo
3.2.2 Starting a Render Job
3.2.3 Dragging and Dropping Files
3.2.4 File Associations
3.2.5 Tutorials
3.2.6 Understanding File Types
3.2.6.1 POV Files
3.2.6.2 INI Files
3.2.6.2.1 INI File Sections
3.2.7 Using the Internal Editor
3.2.7.1 The Editor Feature Set
3.2.7.2 Turning the Internal Editor On or Off
3.2.7.3 Preventing File Restore
3.2.7.4 Switching between Editor windows
3.2.7.5 Keyword Expansion and CodeList
3.2.7.5.1 A Quick Example
3.2.7.5.2 How Keyword Expansion Works
3.2.7.5.3 CodeList
3.2.7.5.4 Using CodeList
3.2.7.5.5 Summary
3.2.7.6 Configuring the Internal Editor
3.2.7.6.1 Important Editor Notes
3.2.7.6.2 Default Key Mappings
3.2.7.6.3 Setting Key Mappings
3.2.7.6.4 Reserved Keys
3.2.7.6.5 Using the Mouse
3.2.7.6.6 Hints for Match Brace
3.2.7.7 The Language Setting
3.2.7.8 The Font Setting
3.2.8 I/O Restrictions
3.2.8.1 High-Level Configuration
3.2.8.2 Overall Options
3.2.8.3 No Restrictions
3.2.8.4 Restrict Write but Allow Read
3.2.8.5 Restrict Read/Write
3.2.8.6 Restrictions Affect all Core File I/O
3.2.8.7 Additional Options
3.2.8.8 Permit Read/Write in Current Directory
3.2.8.9 Disable Starting other Programs
3.2.8.10 Low-Level Configuration
3.2.8.11 Overall Concept
3.2.8.12 Implicitly Permitted Locations
3.2.8.13 Adding or Changing Allowed Directories
3.2.8.14 For Those Who use an Image Output Directory
3.3 Command-Line Options
3.3.1 POV-Ray Documents Directory
3.3.2 Special Command-Line Options
3.3.3 The Benchmark Command-line Option
3.3.4 Non-Standard Installations
3.3.4.1 Background
3.3.4.2 The /INSTALL and /QINSTALL switches
3.3.4.3 Publishing via Group Policy
3.3.4.4 System Admins / Lab Techs
3.3.5 Adding New Resolutions
3.4 Windows
3.4.1 The Main Window
3.4.2 The Toolbar
3.4.2.1 Preset Rendering Options
3.4.2.2 Toolbar Command Line
3.4.3 The Status Bar
3.4.4 The Tab Control
3.4.5 The Message Window
3.4.6 The Editor Window
3.4.7 The Render Window
3.5 Menus
3.5.1 File Menu
3.5.1.1 New File
3.5.1.2 Open File
3.5.1.3 Close
3.5.1.4 Close All
3.5.1.5 Print
3.5.1.6 Exit
3.5.1.7 MRU List
3.5.1.8 Older Files sub-menu
3.5.2 Edit Menu
3.5.2.1 Copy Pane
3.5.2.2 Clear Messages
3.5.2.3 Undo
3.5.2.4 Redo
3.5.2.5 Cut
3.5.2.6 Copy
3.5.2.7 Paste
3.5.2.8 Delete
3.5.2.9 Select All
3.5.2.10 Selection sub-menu
3.5.2.10.1 Indent
3.5.2.10.2 Indent To Previous
3.5.2.10.3 Undent
3.5.2.10.4 Uppercase
3.5.2.10.5 Lowercase
3.5.2.10.6 Convert Spaces To Tabs
3.5.2.10.7 Convert Tabs To Spaces
3.5.3 Search Menu
3.5.3.1 Find dialog
3.5.3.1.1 Match Whole Word Only
3.5.3.1.2 Match Case
3.5.3.1.3 Wildcard Search
3.5.3.2 Replace
3.5.3.3 Find Next
3.5.3.4 Match Brace
3.5.4 Text Menu
3.5.4.1 Show White Space
3.5.4.2 Set Repeat Count
3.5.4.3 Tab Size
3.5.4.4 Indent sub-menu
3.5.4.4.1 Auto-Indent Style sub-menu
3.5.4.4.2 None
3.5.4.4.3 Language Scope
3.5.4.4.4 Copy From Previous Line
3.5.4.5 Bookmarks sub-menu
3.5.4.5.1 Clear All
3.5.4.5.2 First
3.5.4.5.3 Last
3.5.4.5.4 Next
3.5.4.5.5 Previous
3.5.4.5.6 Toggle
3.5.5 Editor Menu
3.5.5.1 Auto-Load Error File
3.5.5.2 Auto-Show Parse Messages
3.5.5.3 Auto-Save Delay
3.5.5.4 Create Backups
3.5.5.5 Allow Undo After Manual Save
3.5.5.6 Click Beyond EOL
3.5.5.7 Constrain Caret To Text
3.5.5.8 Overlay Keyword Expansion On Tab Key
3.5.5.9 Show Message Window
3.5.5.10 Editor Preferences dialog
3.5.5.11 Record Macro/Play Macro
3.5.5.12 Auto-Reload sub-menu
3.5.5.13 Scroll Bars sub-menu
3.5.5.14 Color Scheme sub-menu
3.5.5.15 Editor Preferences
3.5.5.15.1 Color/Font
3.5.5.15.1.1 Item
3.5.5.15.1.2 Color
3.5.5.15.1.3 Background
3.5.5.15.1.4 Font
3.5.5.15.2 Language/Tabs
3.5.5.15.2.1 Auto Indentation Style
3.5.5.15.2.2 Tabs
3.5.5.15.2.3 Language
3.5.5.15.3 Keyboard
3.5.5.15.4 Misc
3.5.5.15.4.1 Smooth Scrolling
3.5.5.15.4.2 Show Left Margin
3.5.5.15.4.3 Line Tooltips on Scroll
3.5.5.15.4.4 Allow Drag and Drop
3.5.5.15.4.5 Allow Column Selection
3.5.5.15.4.6 Confine Caret to Text
3.5.5.15.4.7 Color Syntax Highlighting
3.5.5.15.4.8 Show Horizontal/Vertical Scrollbar
3.5.5.15.4.9 Allow Horizontal/Vertical Splitting
3.5.5.15.4.10 Line Numbering
3.5.5.15.4.11 Max Undoable Actions
3.5.6 Insert Menu
3.5.6.1 Physical Layout
3.5.6.2 Sorting the Insert Menu
3.5.6.3 Adding a Separator
3.5.6.4 Using the Insert Menu
3.5.7 Render Menu
3.5.7.1 Edit Settings/Render dialog
3.5.7.2 Select File and Render dialog
3.5.7.3 Start Rendering (Go!)/Stop Rendering
3.5.7.4 Run Demo
3.5.7.5 Run Benchmark
3.5.7.6 File Queue dialog
3.5.7.7 Clear Queue
3.5.7.8 Render Priority sub-menu
3.5.7.9 Duty Cycle sub-menu
3.5.7.10 Thread Count dialog
3.5.7.11 Prevent Sleep
3.5.7.12 Sound Settings dialog
3.5.7.13 On Completion sub-menu
3.5.7.13.1 Do Nothing
3.5.7.13.2 Display Message
3.5.7.13.3 Exit POV-Ray for Windows
3.5.7.13.4 File List
3.5.8 Options Menu
3.5.8.1 Keep Single Instance
3.5.8.2 Show Toolbar
3.5.8.3 Place in System Tray
3.5.8.4 Script I/O Restrictions
3.5.8.5 Drag'N'Drop Destination sub-menu
3.5.8.6 Update Checks sub-menu
3.5.8.6.1 Periodically Check for Updates
3.5.8.6.2 Include System Information
3.5.8.6.3 Check for Update Now
3.5.8.7 Other Settings sub-menu
3.5.8.7.1 Video Source sub-menu
3.5.8.7.2 Use Editor
3.5.8.7.3 Show Tips of the Day
3.5.8.7.4 Show Tooltips
3.5.8.7.5 Preserve Messages
3.5.8.7.6 Save Settings on Exit
3.5.8.7.7 Hide New User Help
3.5.8.7.8 Show Next Tip
3.5.8.7.9 Re-Render Insert Menu Bitmaps
3.5.8.7.10 Message Window sub-menu
3.5.8.7.11 Select Plain Background
3.5.8.7.12 Text Font
3.5.8.7.13 Text Color
3.5.8.7.14 Background Color
3.5.8.7.15 Tiling Options
3.5.8.7.16 Render Window sub-menu
3.5.8.7.17 Force 8 Bit Display
3.5.8.7.18 Preserve Contents During Animation
3.5.8.7.19 Re-Display
3.5.8.7.20 Autoclose
3.5.8.7.21 Close
3.5.8.7.22 Keep Above Main
3.5.8.7.23 Get Focus on Creation
3.5.8.7.24 Hide When Main Minimized
3.5.8.7.25 Editor Window sub-menu
3.5.9 Tools Menu
3.5.9.1 PVTOOLS.INI Syntax
3.5.9.2 Reload Tool Menu
3.5.9.3 Edit PVTOOLS.INI
3.5.9.4 Example PVTOOLS.INI
3.5.10 Window Menu
3.5.11 Context Menus
3.5.11.1 The Message Window context menu
3.5.11.2 Minimize to System Tray
3.5.11.3 Show Tip
3.5.11.4 The Render Window context menu
3.5.11.5 The Editor Window context menu
3.5.11.6 Show or Hide Messages
3.5.11.7 Context Help
3.5.11.8 Open Filename
3.5.11.9 Copy ... to Command-Line
3.6 Bug Reports
3.6.1 Bugs and GUI Extensions
3.6.2 Crash Upload Utility
3.6.3 Bug Reporting via Email
3.6.4 Bug Reporting via our Bug Tracking System
3.7 Speed Considerations
3.7.1 Render Priority
3.7.2 Render Window
3.7.3 Memory
3.7.4 Scene Features
3.7.5 Render Quality

POV-Ray for Mac OS

4.1 Introduction
4.1.1 What's new in POV-Ray for Mac OS
4.1.2 Requirements
4.1.3 Installation
4.1.4 Bug Reporting via our Bug Tracking System
4.2 Getting Started
4.3 Tips and Tricks
4.3.1 How to use TrueType fonts with the text object
4.3.2 Known Problems

POV-Ray for Unix

5.1 Introduction
5.1.1 What is POV-Ray?
5.1.2 What is POV-Ray for Unix?
5.1.3 ... And What Is It Not?
5.1.4 Who Can Use POV-Ray for Unix?
5.1.5 Spelling
5.1.6 Reporting Bugs
5.1.7 Trademarks
5.2 Features
5.2.1 New Features
5.2.2 Display Options
5.2.3 Benchmark Mode
5.2.4 Sample scene render scripts
5.2.5 KDE Integration
5.3 Getting Started
5.3.1 Available distributions
5.3.2 Configuration
5.3.2.1 The I/O Restrictions configuration file
5.3.2.2 The main POV-Ray INI file
5.3.3 Starting a Render Job
5.3.3.1 X Window display
5.3.3.2 SVGAlib display
5.3.3.3 Output file formats
5.3.4 Interrupting POV-Ray
5.3.5 Tutorials
5.3.6 Rendering the Sample Scenes
5.3.7 POV-Ray for Unix Tips
5.3.7.1 Automated execution
5.3.7.2 Post-processing Images
5.4 I/O Restrictions
5.4.1 Configuration file format
5.4.2 File I/O Security
5.4.3 Shellout Security
5.4.4 Permitted Paths
5.4.4.1 Examples for path settings
5.4.5 Example configuration file
5.5 Understanding File Types
5.5.1 POV Files
5.5.2 INI Files
5.5.2.1 INI File Sections
5.6 Understanding POV-Ray Options
5.6.1 Special Command-Line Options
5.6.2 Benchmark Rendering Mode
5.7 Bug Reports
5.7.1 Known Bugs
5.7.2 Bug Reporting via Email
5.7.3 Bug Reporting via our Bug Tracking System
5.8 Speed Considerations
5.8.1 Render Priority
5.8.2 Render Window
5.8.3 Memory
5.8.4 Scene Features
5.8.5 Render Quality


This document is protected, so submissions, corrections and discussions should be held on this documents talk page.

Personal tools
Variants
Actions
Content
Other Pages
Toolbox